Vulnerability · high · CVSS 8.7
CVE-2026-85111: Apache James denial of service during MIME parsing
Tier C · Keep an eye on it – Check if you’re affected
Who’s exposed: Apache James servers before 3.9.1 parsing untrusted MIME messages
Tier C because: Hits tech teams
Reach
Attack
Damage
Fix
Remote, no login
What to do
- Upgrade Apache James to 3.9.1 or later
The Brief
- CVE-2026-85111 is a denial-of-service vulnerability in Apache James during MIME parsing.
- Affected versions are Apache James before 3.9.1.
- The issue lies in the Apache Mime4J library, with the description citing allocation of resources without limits or throttling. The source lists CVSS 4.0 8.7 (high), network-reachable with no privileges or user interaction, and high availability impact.
Why it matters
Mail servers running Apache James before 3.9.1 can be made unavailable by crafted MIME input, so operators should upgrade to 3.9.1 or later.
The checklist behind the tier
Checklist · 2 of 10 yes
| Yes | Hits tech teams | Apache James is a mail server; mail servers are infrastructure developers and ops teams run. |
| No | Core infrastructure | Apache James is a single mail server product, not software nearly every team runs. |
| No | Popular tool | Apache James is a niche mail server, not a widely used framework or mainstream developer tool. |
| No | Exploited in the wild | Open Source Security advisory describes the DoS flaw only; no observed attacks reported. |
| No | Public exploit | Open Source Security advisory only; no exploit code or proof-of-concept mentioned. |
| Yes | Remote, no login | CVSSCVE-2026-85111: CVSS 8.7 – network, no privileges, no user interaction |
| No | Full takeover | CVSSCVSS: no CVE has both high confidentiality and integrity impact |
| No | Secrets exposed | Open Source Security describes denial of service only; no data exposure reported. |
| No | Supply chain | Open Source Security describes a normal vulnerability in legitimate code; no malicious code shipped. |
| No | No fix yet | Open Source Security says affected versions are before 3.9.1 but does not state that no fix exists. |
The official record
From CVE.org, CISA’s Known Exploited Vulnerabilities catalog, FIRST EPSS and the GitHub Advisory Database. Where these answer a checklist fact, they win over the reporting.
CVE-2026-85111 ↗CVSS 8.7 high AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Apache James: Denial of service upon MIME parsing
- Exploited
- Not in CISA’s exploited catalog
- Weakness
- CWE-770
Timeline
Source
CVE-2026-85111: Apache James: Denial of service upon MIME parsing ↗ Open Source Security · 2h ago
First seen · 1 source · Full story page · How tiers are decided